ide@s server: “:::Implementing a Cloud Storage and Cloud Computing Services With ownCloud 3 On Ubuntu 10.04Lts Server Edition part 1:::”

from webupd8
ownCloud is a free software alternative to some proprietary web services that includes music streaming, file management which supports sharing, calendar, contacts and more:

ownCloud offers the ease-of-use of Dropbox and box.net with a more secure, transparently managed offering. As an open source project ownCloud 3 offers innovative features, a flexible architecture and no vendor lock in. ownCloud 3 has been released recently with some cool new features, such as:- Built-in cloud text editor that supports 35 programming languages for syntax highlighting, keyboard shortcuts support, automatic indent and outdent, unstructured / user code folding and live syntax checker (for JavaScript, Coffee and CSS). Editing more advanced file types like .doc and .odt is planned for a future release:

owncloud 3 text editor

- Integrated PDF viewer:owncloud 3

- Photo gallery application with automatic album generation and dynamic covers:

owncloud 3

Other changes in ownCloud 3:

  • Application Store: support for installing third party applications and addons through a central repository, directly from the ownCloud interface
  • new calendar interface
  • various calendar and contacts improvements
  • A new “external” application that lets you integrate external applications (like an external webmail interface for instance) into the ownCloud interface

The complete list of new features and improvements can be found HERE. Unfortunately, this release doesn’t bring encryption, a desktop sync client or versioning/recovery yet, features which many consider extremely important, but fortunately, all of these features are top priority so hopefully we’ll see all of them in a future ownCloud release.

Download / try ownCloud

If you want to try out ownCloud without installing it, head over to http://demo.owncloud.org

ownCloud is available in the official Ubuntu repositories, but that’s a very old version (pre version 2) so to install the latest ownCloud in Ubuntu, see our initial post about ownCloud: ownCloud: Your Personal Cloud Server.

Arch Linux users can install ownCloud via AUR, however, at the time I’m writing this post, the package hasn’t been updated with the latest ownCloud 3.

Download ownCloud | Update: the ownCloud website seems to be down for now, so here’s an alternate download link (via ownCloud @ Twitter).

“cya to the next 1…. Njoy !”

ide@s desktop: “:::How to Convert a Movie in Avi to DVD Mpeg2 With Devede or FFmpeg on Ubuntu 11.10 Desktop Edition:::”

from nixCraft

DeVeDe is a program or front-end to command line utilities to create video DVDs and CDs (VCD, sVCD or CVD), suitables for home players, from any number of video files, in any of the formats supported by Mplayer. The big advantage over other utilities is that it only needs Mplayer, Mencoder, DVDAuthor, VCDImager and MKisofs (well, and Python 2.4, PyGTK and PyGlade), so its dependencies are really small.

Install DeVeDe

Use apt-get command to install DeVeDe:

$: sudo apt-get install devede ffmpeg 

To create dvds just type devede at command prompt:

$: devede &

You can also start devede by visiting Applications > Sound & Video > Devede

Just choose the DVD / VCD type and follow on screen instructions.

Create DVD from command line

Following tools get installed with devede:

  1. mencoder : MPlayer’s Movie Encoder) is a simple movie encoder
  2. ffmpeg : FFmpeg video converter
  3. dvdauthor : assembles multiple mpeg program streams into a suitable DVD filesystem

So if you are a pro command line user, type the following commands to convert file1.avi fille2.avi to DVD format (if you are not comfortable with command line use devede GUI software and just skip following commands) :

$: cat file1.avi file2.avi > ccmovie.avi

Now run movie encoder to create out.avi from ccmovie.avi (option -ovc and -oac sets no encoding, just streamcopy)

$: mencoder -o out.avi -noidx -oac copy -ovc copy ccmovie.avi

Output:

MEncoder 2:1.0~rc1-0ubuntu13 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
success: format: 0  data: 0x0 - 0x385ceda
AVI file format detected.
VIDEO:  [MP42]  544x400  24bpp  29.970 fps  485.6 kbps (59.3 kbyte/s)
[V] filefmt:3  fourcc:0x3234504D  size:544x400  fps:29.97  ftime:=0.0334
videocodec: framecopy (544x400 24bpp fourcc=3234504d)
audiocodec: framecopy (format=55 chans=2 rate=44100 bits=0 B/s=16743 sample-0)
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
Writing index...99f (100%)  0.00fps Trem:   0min  55mb  A-V:0.013 [474:133]
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
Video stream:  474.111 kbit/s  (59263 B/s)  size: 45083566 bytes  760.727 secs  22799 frames
Audio stream:  133.948 kbit/s  (16743 B/s)  size: 12736975 bytes  760.712 secs

Next run FFmpeg video converter to set aspect ratio, ntsc dvd television standard etc:

$: ffmpeg -i movie.avi -y -target pal-dvd -sameq -aspect 16:9 movie.mpg

Output:

FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-shared --prefix=/usr
  libavutil version: 1d.49.3.0
  libavcodec version: 1d.51.38.0
  libavformat version: 1d.51.10.0
  built on Jun  3 2007 20:59:25, gcc: 4.1.3 20070528 (prerelease) (Ubuntu 4.1.2-9ubuntu2)
Input #0, avi, from 'out.avi':
  Duration: 00:12:40.7, start: 0.000000, bitrate: 621 kb/s
  Stream #0.0: Video: msmpeg4v2, yuv420p, 544x400, 29.97 fps(r)
  Stream #0.1: Audio: mp3, 44100 Hz, stereo, 32 kb/s
Output #0, dvd, to 'out.mpg':
  Stream #0.0: Video: mpeg2video, yuv420p, 720x480, q=2-31, 6000 kb/s, 29.97 fps(c)
  Stream #0.1: Audio: ac3, 48000 Hz, stereo, 448 kb/s
Stream mapping:
  Stream #0.0 -> #0.0
  Stream #0.1 -> #0.1
Press [q] to stop encoding
frame=22798 q=0.0 Lsize=  312758kB time=760.7 bitrate=3368.3kbits/s

At a high level, a DVD is a collection of menus and titles. Conceptually, a menu contains buttons which can be assigned actions and provides a list of choices to the end user, while a title contains the main content of the DVD. However, in reality many of the features available in menus (including buttons, pausing, and looping) are also available in titles. Use dvdauthor assembles multiple mpeg program streams into a suitable DVD filesystem. You should see DVD filesytem in dvd directory:

$: dvdauthor --title -o dvd -f out.mpg 

Output:

DVDAuthor::dvdauthor, version 0.6.14.
Build options: gnugetopt magick iconv freetype
Send bugs to <dvdauthor-users@lists.sourceforge.net>
INFO: dvdauthor creating VTS
STAT: Picking VTS 01
STAT: Processing out.mpg...
STAT: VOBU 1888 at 304MB, 1 PGCS
INFO: Video pts = 0.500 .. 761.193
INFO: Audio[0] pts = 0.500 .. 761.204
STAT: VOBU 1900 at 305MB, 1 PGCS
INFO: Generating VTS with the following video attributes:
INFO: MPEG version: mpeg2
INFO: TV standard: ntsc
INFO: Aspect ratio: 16:9
INFO: Resolution: 720x480
INFO: Audio ch 0 format: ac3/2ch, 48khz drc
STAT: fixed 1900 VOBUS

Creates the table of contents file instead of a titleset:

$: dvdauthor -o dvd -T

Output:

DVDAuthor::dvdauthor, version 0.6.14.
Build options: gnugetopt magick iconv freetype
Send bugs to <dvdauthor-users@lists.sourceforge.net>
INFO: dvdauthor creating table of contents
INFO: Scanning dvd/VIDEO_TS/VTS_01_0.IFO

Create dvd.iso:

$: mkisofs -dvd-video -o dvd.iso dvd/

Output:

Setting input-charset to 'UTF-8' from locale.
  3.20% done, estimate finish Fri Nov  9 16:49:50 2007
  6.38% done, estimate finish Fri Nov  9 16:49:50 2007
  9.57% done, estimate finish Fri Nov  9 16:49:50 2007
 12.76% done, estimate finish Fri Nov  9 16:49:50 2007
 15.95% done, estimate finish Fri Nov  9 16:49:50 2007
 19.13% done, estimate finish Fri Nov  9 16:49:50 2007
 22.33% done, estimate finish Fri Nov  9 16:49:54 2007
 25.51% done, estimate finish Fri Nov  9 16:49:53 2007
 28.70% done, estimate finish Fri Nov  9 16:49:53 2007
 31.88% done, estimate finish Fri Nov  9 16:49:53 2007
 35.08% done, estimate finish Fri Nov  9 16:49:52 2007
 38.26% done, estimate finish Fri Nov  9 16:49:52 2007
 41.45% done, estimate finish Fri Nov  9 16:49:52 2007
 44.64% done, estimate finish Fri Nov  9 16:49:54 2007
 47.83% done, estimate finish Fri Nov  9 16:49:54 2007
 51.01% done, estimate finish Fri Nov  9 16:49:53 2007
 54.21% done, estimate finish Fri Nov  9 16:49:53 2007
 57.39% done, estimate finish Fri Nov  9 16:49:53 2007
 60.58% done, estimate finish Fri Nov  9 16:49:53 2007
 63.77% done, estimate finish Fri Nov  9 16:49:54 2007
 66.96% done, estimate finish Fri Nov  9 16:49:54 2007
 70.14% done, estimate finish Fri Nov  9 16:49:54 2007
 73.33% done, estimate finish Fri Nov  9 16:49:54 2007
 76.52% done, estimate finish Fri Nov  9 16:49:53 2007
 79.71% done, estimate finish Fri Nov  9 16:49:53 2007
 82.89% done, estimate finish Fri Nov  9 16:49:53 2007
 86.09% done, estimate finish Fri Nov  9 16:49:53 2007
 89.27% done, estimate finish Fri Nov  9 16:49:54 2007
 92.46% done, estimate finish Fri Nov  9 16:49:55 2007
 95.65% done, estimate finish Fri Nov  9 16:49:55 2007
 98.84% done, estimate finish Fri Nov  9 16:49:55 2007
Total translation table size: 0
Total rockridge attributes bytes: 0
Total directory bytes: 4096
Path table size(bytes): 42
Max brk space used 0
156833 extents written (306 MB)

Burn dvd.iso to DVD disk:

$: growisofs -dvd-compat -dvd-video -speed=4 -Z /dev/dvd dvd/*

“cya to the next 1…. Njoy !”

ide@s server: “:::Configuring the Uncomplicated Firewall (UFW) of Canonical on Ubuntu 10.04Lts Server Desktop:::”

from Ubuntu Documentation

The default firewall configuration tool for Ubuntu is ufw. Developed to ease iptables firewall configuration, ufw provides a user friendly way to create an IPv4 or IPv6 host-based firewall.

ufw by default is initially disabled. From the ufw man page:

“ ufw is not intended to provide complete firewall functionality via its command interface, but instead provides an easy way to add or remove simple rules. It is currently mainly used for host-based firewalls. ”

The following are some examples of how to use ufw:

  • First, ufw needs to be enabled. From a terminal prompt enter:
    sudo ufw enable
  • To open a port (ssh in this example):
    sudo ufw allow 22
  • Rules can also be added using a numbered format:
    sudo ufw insert 1 allow 80
  • Similarly, to close an opened port:
    sudo ufw deny 22
  • To remove a rule, use delete followed by the rule:
    sudo ufw delete deny 22
  • It is also possible to allow access from specific hosts or networks to a port. The following example allows ssh access from host 192.168.0.2 to any ip address on this host:
    sudo ufw allow proto tcp from 192.168.0.2 to any port 22

    Replace 192.168.0.2 with 192.168.0.0/24 to allow ssh access from the entire subnet.

  • Adding the –dry-run option to a ufw command will output the resulting rules, but not apply them. For example, the following is what would be applied if opening the HTTP port:
     sudo ufw --dry-run allow http
    
    *filter :ufw-user-input - [0:0] :ufw-user-output - [0:0] :ufw-user-forward - [0:0] :ufw-user-limit - [0:0] :ufw-user-limit-accept - [0:0] ### RULES ### ### tuple ### allow tcp 80 0.0.0.0/0 any 0.0.0.0/0 -A ufw-user-input -p tcp --dport 80 -j ACCEPT ### END RULES ### -A ufw-user-input -j RETURN -A ufw-user-output -j RETURN -A ufw-user-forward -j RETURN -A ufw-user-limit -m limit --limit 3/minute -j LOG --log-prefix "[UFW LIMIT]: " -A ufw-user-limit -j REJECT -A ufw-user-limit-accept -j ACCEPT COMMIT Rules updated
  • ufw can be disabled by:
    sudo ufw disable
  • To see the firewall status, enter:
    sudo ufw status
  • And for more verbose status information use:
    sudo ufw status verbose
  • To view the numbered format:
    sudo ufw status numbered
[Note]
If the port you want to open or close is defined in /etc/services, you can use the port name instead of the number. In the above examples, replace 22 with ssh.

This is a quick introduction to using ufw. Please refer to the ufw man page for more information.

ufw Application Integration

Applications that open ports can include an ufw profile, which details the ports needed for the application to function properly. The profiles are kept in /etc/ufw/applications.d, and can be edited if the default ports have been changed.

  • To view which applications have installed a profile, enter the following in a terminal:
    sudo ufw app list
  • Similar to allowing traffic to a port, using an application profile is accomplished by entering:
    sudo ufw allow Samba
  • An extended syntax is available as well:
    ufw allow from 192.168.0.0/24 to any app Samba

    Replace Samba and 192.168.0.0/24 with the application profile you are using and the IP range for your network.

    [Note]
    There is no need to specify the protocol for the application, because that information is detailed in the profile. Also, note that the app name replaces the port number.
  • To view details about which ports, protocols, etc are defined for an application, enter:
    sudo ufw app info Samba

Not all applications that require opening a network port come with ufw profiles, but if you have profiled an application and want the file to be included with the package, please file a bug against the package in Launchpad.

IP Masquerading

The purpose of IP Masquerading is to allow machines with private, non-routable IP addresses on your network to access the Internet through the machine doing the masquerading. Traffic from your private network destined for the Internet must be manipulated for replies to be routable back to the machine that made the request. To do this, the kernel must modify the source IP address of each packet so that replies will be routed back to it, rather than to the private IP address that made the request, which is impossible over the Internet. Linux uses Connection Tracking (conntrack) to keep track of which connections belong to which machines and reroute each return packet accordingly. Traffic leaving your private network is thus “masqueraded” as having originated from your Ubuntu gateway machine. This process is referred to in Microsoft documentation as Internet Connection Sharing.

ufw Masquerading

IP Masquerading can be achieved using custom ufw rules. This is possible because the current back-end for ufw is iptables-restore with the rules files located in /etc/ufw/*.rules. These files are a great place to add legacy iptables rules used without ufw, and rules that are more network gateway or bridge related.

The rules are split into two different files, rules that should be executed before ufw command line rules, and rules that are executed after ufw command line rules.

  • First, packet forwarding needs to be enabled in ufw. Two configuration files will need to be adjusted, in /etc/default/ufw change the DEFAULT_FORWARD_POLICY to “ACCEPT”:
    DEFAULT_FORWARD_POLICY="ACCEPT"

    Then edit /etc/ufw/sysctl.conf and uncomment:

    net/ipv4/ip_forward=1

    Similarly, for IPv6 forwarding uncomment:

    net/ipv6/conf/default/forwarding=1
  • Now we will add rules to the /etc/ufw/before.rules file. The default rules only configure the filter table, and to enable masquerading the nat table will need to be configured. Add the following to the top of the file just after the header comments:
    # nat Table rules
    *nat
    :POSTROUTING ACCEPT [0:0]
    
    # Forward traffic from eth1 through eth0.
    -A POSTROUTING -s 192.168.0.0/24 -o eth0 -j MASQUERADE
    
    # don't delete the 'COMMIT' line or these nat table rules won't be processed
    COMMIT

    The comments are not strictly necessary, but it is considered good practice to document your configuration. Also, when modifying any of the rules files in /etc/ufw, make sure these lines are the last line for each table modified:

    # don't delete the 'COMMIT' line or these rules won't be processed
    COMMIT

    For each Table a corresponding COMMIT statement is required. In these examples only the nat and filter tables are shown, but you can also add rules for the raw and mangle tables.

    [Note]
    In the above example replace eth0, eth1, and 192.168.0.0/24 with the appropriate interfaces and IP range for your network.
  • Finally, disable and re-enable ufw to apply the changes:
    sudo ufw disable && sudo ufw enable

IP Masquerading should now be enabled. You can also add any additional FORWARD rules to the /etc/ufw/before.rules. It is recommended that these additional rules be added to the ufw-before-forward chain.

iptables Masquerading

iptables can also be used to enable masquerading.

  • Similar to ufw, the first step is to enable IPv4 packet forwarding by editing /etc/sysctl.conf and uncomment the following line
    net.ipv4.ip_forward=1

    If you wish to enable IPv6 forwarding also uncomment:

    net.ipv6.conf.default.forwarding=1
  • Next, execute the sysctl command to enable the new settings in the configuration file:
    sudo sysctl -p
  • IP Masquerading can now be accomplished with a single iptables rule, which may differ slightly based on your network configuration:
    sudo iptables -t nat -A POSTROUTING -s 192.168.0.0/16 -o ppp0 -j MASQUERADE

    The above command assumes that your private address space is 192.168.0.0/16 and that your Internet-facing device is ppp0. The syntax is broken down as follows:

    • -t nat — the rule is to go into the nat table
    • -A POSTROUTING — the rule is to be appended (-A) to the POSTROUTING chain
    • -s 192.168.0.0/16 — the rule applies to traffic originating from the specified address space
    • -o ppp0 — the rule applies to traffic scheduled to be routed through the specified network device
    • -j MASQUERADE — traffic matching this rule is to “jump” (-j) to the MASQUERADE target to be manipulated as described above
  • Also, each chain in the filter table (the default table, and where most or all packet filtering occurs) has a default policy of ACCEPT, but if you are creating a firewall in addition to a gateway device, you may have set the policies to DROP or REJECT, in which case your masqueraded traffic needs to be allowed through the FORWARD chain for the above rule to work:
    sudo iptables -A FORWARD -s 192.168.0.0/16 -o ppp0 -j ACCEPT
    sudo iptables -A FORWARD -d 192.168.0.0/16 -m state --state ESTABLISHED,RELATED -i ppp0 -j ACCEPT

    The above commands will allow all connections from your local network to the Internet and all traffic related to those connections to return to the machine that initiated them.

  • If you want masquerading to be enabled on reboot, which you probably do, edit /etc/rc.local and add any commands used above. For example add the first command with no filtering:
    iptables -t nat -A POSTROUTING -s 192.168.0.0/16 -o ppp0 -j MASQUERADE

Logs

Firewall logs are essential for recognizing attacks, troubleshooting your firewall rules, and noticing unusual activity on your network. You must include logging rules in your firewall for them to be generated, though, and logging rules must come before any applicable terminating rule (a rule with a target that decides the fate of the packet, such as ACCEPT, DROP, or REJECT).

If you are using ufw, you can turn on logging by entering the following in a terminal:

sudo ufw logging on

To turn logging off in ufw, simply replace on with off in the above command.

If using iptables instead of ufw, enter:

sudo iptables -A INPUT -m state --state NEW -p tcp --dport 80 -j LOG --log-prefix "NEW_HTTP_CONN: "

A request on port 80 from the local machine, then, would generate a log in dmesg that looks like this:

 

[4304885.870000] NEW_HTTP_CONN: IN=lo OUT= MAC=00:00:00:00:00:00:00:00:00:00:00:00:08:00 SRC=127.0.0.1 DST=127.0.0.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=58288 DF PROTO=TCP SPT=53981 DPT=80 WINDOW=32767 RES=0x00 SYN URGP=0

 

The above log will also appear in /var/log/messages, /var/log/syslog, and /var/log/kern.log. This behavior can be modified by editing /etc/syslog.conf appropriately or by installing and configuring ulogd and using the ULOG target instead of LOG. The ulogd daemon is a userspace server that listens for logging instructions from the kernel specifically for firewalls, and can log to any file you like, or even to a PostgreSQL or MySQL database. Making sense of your firewall logs can be simplified by using a log analyzing tool such as fwanalog, fwlogwatch, or lire.

“cya to the next 1…. Njoy !”

ide@s desktop: “:::How Install and Configure FwBuilder as a Desktop Firewall on Ubuntu 11.10 Desktop Edition:::”

Firewall Builder (also known as fwbuilder) is a GUI firewall configuration and management tool that supports iptables (netfilter), ipfilter, pf, ipfw, Cisco PIX (FWSM, ASA) and Cisco routers extended access lists. Both professional network administrators and hobbyists managing firewalls with policies more complex that is allowed by simple web based UI can simplify management tasks with the application.

Let’s start we to take the package, the link where to get it is the following

http://sourceforge.net/projects/fwbuilder/files/Current_Packages/5.0.1/

in my case I’ve chose fwbuilder_5.0.1.3592-ubuntu-oneiric-1_amd64.deb. Once it’s been installed we need to create the directory that will contain the file compiled from fwbuilder.

$: sudo mkdir /etc/fwbuilder $: sudo chgrp ric /etc/fwbuilder $: sudo chmod g+w /etc/fw

ok, now open the application and select the button “Create new firewall”,

give a name of our firewall eg. DesktopFirewall. Leave the the option “Configure interfaces manually”, adding the interface used of the firewall with its IP address. At this point select our firewall, DesktopFirewall,and on the bottom of it click the button “Firewall Settings…” and configure it as reported of the picture, obviously with your parameters.

After this step, we can populate our firewall, DesktopFirewall. I’ve started using a configuration like that

after I’ve made the compile and the Installation of the roles, have made it a bit complicate adding more roles.

My base model of firewall with fwBuilder

The last step is to make FwBuilder bootable every time that you run on your PC. To Make that from the terminal launch the command

$: sudo nano /etc/rc.local

and adding the line before the exit 0

/etc/fwbuilder/RiccardoDesktopFirewall.fw

reboot the machine

“cya to the next 1…. Njoy !”

ide@s desktop: “:::Installing The New Unity 2D ver. 5.2 on Ubuntu 11.10 Desktop Edition:::”

from terminal launch the following cokmmands:

$: sudo apt-add-repository ppa:unity-team/staging 
$: sudo apt-get update 
$: sudo apt-get install unity-2d

To remove Unity 2D 5.2 and restore the default version can use that ones:

$: sudo apt-get install ppa-purge 
$: sudo ppa-purge ppa:unity-team/staging

“cya to the next 1…. Njoy !”

ide@s networking: “:::Appling The OSPF (Open Shortest Path First) Filtering with Distribute-List and Route-Map on Cisco Router:::”

- OSPF Distribute-List and ACL

LAN fa0/0 (R1) se0/0/0

SWITCH

              se0/0/0 (R2) fa0/0 LAN                

ROUTER1 Configuration

R1(conf)# interface Loopback0 
R1(conf-if)# ip address 172.16.101.1 255.255.255.0 
R1(conf-if)# ip ospf network point-to-point 
R1(conf-if)# exit 
R1(conf)# interface fa0/0 
R1(conf-if)# ip address 192.168.0.254 255.255.255.0 
R1(conf-if)# no frame-relay inverse-arp
R1(conf-if)# exit
R1(conf)# interface se0/0/0 
R1(conf-if)# ip address 10.1.1.1 255.255.255.0
R1(conf-if)# no frame-relay inverse-arp
R1(conf-if)# exit 
R1(conf)# access-list 1 deny 192.168.1.0 0.0.0.255 
R1(conf)# access-list 1 permit any 
R1(conf)# router ospf 1
R1(conf-router)# router-id 1.1.1.1
R1(conf-router)# log-adjacency-changes
R1(conf-router)# network 10.1.1.1 0.0.0.0 area 0
R1(conf-router)# network 192.168.0.254 0.0.0.0 area 1
R1(conf-router)#  distribute-list 1 in 
R2(conf-router)#  exit

ROUTER2 Configuration

R2(conf)# interface Loopback0 
R2(conf-if)# ip address 172.16.102.2 255.255.255.0 
R2(conf-if)#  ip ospf network point-to-point 
R2(conf-if)# end 
R2(conf)# interface fa0/0 
R2(conf-if)# ip address 192.168.1.254 255.255.255.0 
R2(conf-if)# no frame-relay inverse-arp
R2(conf-if)# end
R2(conf)# interface se0/0/0 
R2(conf-if)# ip address 10.1.1.2 255.255.255.0 
R2(conf-if)# no frame-relay inverse-arp
R2(conf-if)# end R2(conf)# router ospf 1
R2(conf-router)# router-id 2.2.2.2
R2(conf-router)# log-adjacency-changes
R2(conf-router)# network 10.1.1.2 0.0.0.0 area 0
R2(conf-router)# network 192.168.1.254 0.0.0.0 area 1
R2(conf-router)#  end

- OSPF Route-Map and Prefix-List


LAN fa0/0 (R1) se0/0/0

SWITCH

se0/0/0 (R2) fa0/0 LAN

ROUTER1 Configuration

R1(conf)# interface Loopback0
 R1(conf-if)# ip address 172.16.101.1 255.255.255.0
 R1(conf-if)#  ip ospf network point-to-point
 R1(conf-if)# exit
 R1(conf)# interface fa0/0
 R1(conf-if)# ip address 192.168.0.254 255.255.255.0
 R1(conf-if)# no frame-relay inverse-arp
 R1(conf-if)# exit
 R1(conf)# interface se0/0/0
 R1(conf-if)# ip address 10.1.1.1 255.255.255.0
 R1(conf-if)# no frame-relay inverse-arp
 R1(conf-if)# exit
 R1(conf)# ip prefix-list R2_FILTERING seq 5 permit 192.168.1.0/24
 R1(conf)# route-map FILTER_PREFIX deny 10
 R1(conf-route-map)# match ip address prefix-list R2_FILTERING
 R1(conf-route-map)# exit
 R1(conf)# route-map FILTER_PREFIX permit 20
 R1(conf-route-map)# end
 R1(conf)# router ospf 1
 R1(conf-router)# router-id 1.1.1.1
 R1(conf-router)# log-adjacency-changes
 R1(conf-router)# network 192.168.0.254 0.0.0.0 area 0
 R1(conf-router)# network 10.1.1.1 0.0.0.0 area 1
 R1(conf-router)# distribute-list route-map FILTER_PREFIX in
 R1(conf-router)# end

ROUTER2 Configuration

R2(conf)# interface Loopback0 
R2(conf-if)# ip address 172.16.102.2 255.255.255.0 
R2(conf-if)#  ip ospf network point-to-point 
R2(conf-if)# end 
R2(conf)# interface fa0/0 
R2(conf-if)# ip address 192.168.1.254 255.255.255.0 
R2(conf-if)# no frame-relay inverse-arp
R2(conf-if)# end
R2(conf)# interface se0/0/0 
R2(conf-if)# ip address 10.1.1.2 255.255.255.0 
R2(conf-if)# no frame-relay inverse-arp
R2(conf-if)# end 
R2(conf)# router ospf 1
R2(conf-router)# router-id 2.2.2.2
R2(conf-router)# log-adjacency-changes
R2(conf-router)# network 10.1.1.2 0.0.0.0 area 0
R2(conf-router)# network 192.168.1.254 0.0.0.0 area 1
R2(conf-router)#  end

“cya to the next 1…. Njoy !”

ide@s networking: “:::Implementing The Authentication MD5 Encryption in OSPF (Open Shortest Path First) Routing Protocol on a Cisco Router:::”

se0/0/0 (R1)

SWITCH

(R2) se0/0/0                se0/0/0 (R3)

ROUTER1 Configuration

R1(conf)# interface Loopback0 
R1(conf-if)# ip address 172.16.101.1 255.255.255.0
R1(conf-if)#  ip ospf network point-to-point 
R1(conf-if)# end 
R1(conf)# interface fa0/0
R1(conf-if)# ip address 10.1.1.1 255.255.255.0
R1(conf-if)# ip ospf authentication message-digest  
R1(conf-if)# ip ospf message-digest-key 1 md5 P4sSw0rD 
R1(conf-if)# no frame-relay inverse-arp 
R1(conf)# router ospf 1
R1(conf-router)# router-id 1.1.1.1
R1(conf-router)# log-adjacency-changes 
R1(conf-router)#  area 0 authentication message-digest 
R1(conf-router)# network 10.1.1.1 0.0.0.0 area 0
R1(conf-router)# network 172.16.101.1 0.0.0.0 area 0
R1(conf-router)# end

ROUTER2 Configuration

R2(conf)# interface Loopback0 
R2(conf-if)# ip address 172.16.102.2 255.255.255.0
R2(conf-if)#  ip ospf network point-to-point 
R2(conf-if)# end R2(conf)# interface fa0/0
R2(conf-if)# ip address 10.1.1.2 255.255.255.0
R2(conf-if)# ip ospf authentication message-digest 
R2(conf-if)# ip ospf message-digest-key 1 md5 P4sSw0rD 
R2(conf-if)# no frame-relay inverse-arp 
R2(conf)# router ospf 1
R2(conf-router)# router-id 2.2.2.2
R2(conf-router)# log-adjacency-changes  
R2(conf-router)#  area 0 authentication message-digest 
R2(conf-router)# network 10.1.1.2 0.0.0.0 area 0
R2(conf-router)# network 172.16.102.2 0.0.0.0 area 0
R2(conf-router)# end

ROUTER3 Configuration

R3(conf)# interface Loopback0 
R3(conf-if)# ip address 172.16.103.3 255.255.255.0
R3(conf-if)#  ip ospf network point-to-point 
R3(conf-if)# end 
R3(conf)# interface fa0/0
R3(conf-if)# ip address 10.1.1.3 255.255.255.0
R3(conf-if)# ip ospf authentication message-digest  
R3(conf-if)# ip ospf message-digest-key 1 md5 P4sSw0rD 
R3(conf-if)# no frame-relay inverse-arp 
R3(conf)# router ospf 1
R3(conf-router)# router-id 3.3.3.3
R3(conf-router)# log-adjacency-changes 
R3(conf-router)#  area 0 authentication message-digest  
R3(conf-router)# network 10.1.1.3 0.0.0.0 area 0
R3(conf-router)# network 172.16.103.3 0.0.0.0 area 0
R3(conf-router)# end

“cya to the next 1…. Njoy !”l

ide@s desktop: “:::How to Realize a Media Center With XBMC (Xbox Media Centre) on an Ubuntu 10.04 Dekstop Edition:::”

Current Stable Release: XBMC ver. 10.1 name code“Dharma”

$: sudo add-apt-repository ppa:team-xbmc 
$: sudo apt-get update 
$: sudo apt-get install xbmc 
$: sudo apt-get upgrade

Current Testing Release: XBMC ver. 11.0 name code “Eden” Beta 2

$: sudo add-apt-repository ppa:team-xbmc/unstable 
$: sudo apt-get update 
$: sudo apt-get install xbmc 
$: sudo apt-get upgrade

The last step is adding support for remote controls.

$: sudo apt­get install lirc

On the remote selection screen, I chose the Windows Media Center Transceivers/Remotes (all).

“cya to the next 1…. Njoy !”

ide@s desktop: “:::How to install Ubuntu`s New Smart Menus, Called HUB, on Ubuntu 12.04Lts Desktop Edition:::”

from webupd8:

Mark Shuttleworth has announced HUD, or Head-Up Display, an alternative to application menus especially designed for Unity, which should solve many issues with existing menus “by connecting users directly to what they want”:

Say hello to the Head-Up Display, or HUD, which will ultimately replace menus in Unity applications. [...] The HUD concept has been the driver for all the work we’ve done in unifying menu systems across Gtk, Qt and other toolkit apps in the past two years. So far, that’s shown up as the global menu. In 12.04, it also gives us the first cut of the HUD.

- Mark Shuttleworth

HUD works everywhere the appmenu (global menu) works and lets you search through the application and system menus. It uses a smart search so it can learn what you do to prioritize various items. Further more, HUD lets you interact with both the focused window as well as the whole application (for instance, you can perform various actions for an IM chat window but also set the status, through the same menu).

Mark is even speaking about integrating voice recognition into HUD, but that will take a while to implement:

Searching is fast and familiar, especially once we integrate voice recognition, gesture and touch. We want to make it easy to talk to any application, and for any application to respond to your voice. The full integration of voice into applications will take some time. But even without voice input, the HUD is faster than mousing through a menu, and easier to use than hotkeys since you just have to know what you want, not remember a specific key combination

In a comment to his blog post, Mark also said that HUD “may be default, but optional”, so it will not replace the regular menus, at least not for now. Also, I’m not sure how this will work in the future, but for the moment, regular menus aren’t removed and they are still displayed on the top panel, so HUD is only an alternate way of using the menus.

Here’s a video introduction to HUD, recorded by the Ubuntu developers:

More about HUD @ http://www.markshuttleworth.com/archives/939

hud unity

According to Mark’s blog post, it’s not yet known if HUD will be available by default in Ubuntu 12.04, but it’s already available to test via PPA (for Ubuntu 12.04 Precise Pangolin only):

$: sudo add-apt-repository ppa:unity-team/hud
$: sudo apt-get update 
$: sudo apt-get upgrade

Then log out and log back in. To invoke the HUD, tap ALT.

Please note that HUD is currently available as a prototype, for testing only and has some missing features. Installing it will replace your current Unity version! Also, the installation might fail if you’ve installed Unity from the staging PPA.

To remove Unity with HUD and go back to the original Unity from the Ubuntu repositories, use the commands below:

$: sudo apt-get install ppa-purge 
$: sudo ppa-purge ppa:unity-team/hud

“cya to the next 1…. Njoy !”